WordPress

很多人在早上看到WordPress後台出現在2.8版更新就給他按下去更新了,運氣好的是什麼問題都沒有,但是真的就是沒問題嗎?

非也!更新好沒有出現問題算你運氣好,要是出問題才是正常的!

你的外掛相容於2.8版嗎?

如果你用了許多的外掛,那出問題的機率又一定大增!因為這一次WordPress的改版範圍算是不小,而且有幾項核心的功能都有變動,所以這一次的改版就會有一大堆的外掛程式還要再跟上來!

這種情形如果是在你新增外掛的時候還可以知道該外掛有沒有相容於2.8版,但是對於你已經在使用中的外掛,你如何能得知是不是跟2.8版相容呢?

有網友很熱心收集了一份清單,裡面列出大家常用的外掛與新版WordPress的相容性,請你在升級之前最好先到這個網站看看:

  • http://www.bravenewcode.com/2009/05/new-wordpress-plugin-compatibility-checker/ WordPress Plugin Compatibility Checker (連結已失效)
WordPress Plugin Compatibility Checker

這個不是官網整理出的資料,但是還是很有參考價值,像這次高登將手上的Gordon's SEO升級,結果升級完後台就進不去了:

WordPress Plugin Compatibility Checker

這次之前高登介面過的Limit Login Attempts外掛出問題了,而且高登特別試了一下,20分鐘之後還是進不去,永遠都要等20分鐘!

遇到這種情形你只要從主機後台cPanel或是Plesk的檔案管理員進去將那一個外掛的目錄改個名稱,或是將整個外掛的目錄刪除就可以了,高登特別在此提供給升級之後出問題的人參考。